Increased CPU Usage (Player V3) - cbtec Video

Incident Report for cbtec Technologies

Postmortem

Instructions on how to fix this problem.

Please ensure that you are running Player Version 3.0.23R20240127 or higher to avoid this issue.

A bug was recently fixed regarding an increase in CPU usage when using the fine scrubber on the video player. This issue has now been Resolved.

Checking the player version is simple: 1. Enter full layout mode by clicking on any video, 2. Right click on the player, 3. Check the bottom of the pop-out.

If you are on an older version, reset your cache by pressing Ctrl+F5 simultaneously or the equivalent for your device or browser.

Problems with Fine Scrubber

Earlier today, we discovered a problem within the Player V3 code that caused the fine scrubber to cause an increase in browser CPU usage when used. This applied to both Miniplayer and full layout video players.

It was discovered that the script had been running actions to track the cursors movements, but hadn't checked if it was already running those actions, causing them to stack and eventually slow down the browser.

In response, the team resolved the problem within a few hours of being made aware of the issue and the video player now performs correctly.

Future

In the future, we hope to learn from this experience to better our release standards to ensure that our software gives the user the best possible experience. We never want to downgrade the user experience seen in the bug reported today.

When developing the original update to streamline the watching experience into a seamless experience, we created our own developer portal to aid in the creation of robust software that can be trusted by our users. From this experience today, we want to continue to use and improve the developer interface so that the end product is suitable, and stands the test of time.

Thank you,

Charlie

Posted Jan 27, 2024 - 20:42 GMT

Resolved

This issue has now been resolved. Please ensure that you are running Player Version 3.0.23R20240127 or higher to avoid this issue. If you are confused, please refer to the Postmortem for further instructions.
Posted Jan 27, 2024 - 19:58 GMT

Monitoring

We've identified and fixed a problem within the script that controls the fine scrubber.

It was discovered that the script had been running actions to track the cursors movements, but hadn't checked if it was already running those actions, causing them to stack and eventually slow down the browser.

A patch has been released and we're verifying everything is correct client-side.
Posted Jan 27, 2024 - 19:48 GMT

Investigating

We recently updated our video player to version 3, meaning you are able to seamlessly transition between Miniplayer and full layout mode.

However, we are investigating a bug in the code running the video player that seems to increase CPU usage while using the fine scrubber. Using the video player without the fine scrubber should function without issues, as the scrubber does not generate images until it is used.

We will keep you all updated on this issue.
Posted Jan 27, 2024 - 17:53 GMT