Degraded Performance

Incident Report for cbtec Technologies

Resolved

This incident has been resolved.
Posted Sep 14, 2024 - 13:24 BST

Investigating

We're noticing degraded or complete failures to complete requests on the content delivery side of our network. We're investigating this.
Posted Sep 14, 2024 - 00:06 BST
This incident affected: cbtec (cbtec.org) and Core Services (EU-003).